Parameters of the ‘Filter and Cut Elements in 3D’ dialog.
typedef struct { short firstStory3D; short lastStory3D; bool allStories; bool inSelect; bool trimToMark; bool wall; bool colu; bool symb; bool light; bool ceil; bool mesh; bool roof; bool shell; bool curtainWall; bool wind; bool door; bool skylight; bool morph; bool beam; bool room; bool filler_1; bool trimToStoryRange; short markRectFloor; short markVertType; API_3DFilterModeID filterMode; Int32 filler_2[8]; } API_3DImageInfo;
Members
- firstStory3D
- First story to convert. Valid only if
allStories
isfalse
- lastStory3D
- Last story to convert. Valid only if
allStories
isfalse
- allStories
- Create a 3D projection of all stories rather than a range of stories defined by
firstStory3D
..lastStory3D
- inSelect
- Image only the elements that are within or outside the marquee area defined in the floor plan
- trimToMark
- Cut the 3D model by the marquee defined in the floor plan
- wall
- Show wall type elements in the 3D projection
- colu
- Show column type elements in the 3D projection
- symb
- Show object type elements in the 3D projection
- light
- Show lamp type elements in the 3D projection
- ceil
- Show slab type elements in the 3D projection
- mesh
- Show mesh type elements in the 3D projection
- roof
- Show roof type elements in the 3D projection
- shell
- Show shells in the 3D projection
- curtainWall
- Show curtain walls in the 3D projection
- wind
- Show window type elements in the 3D projection. If this value is
false
, empty holes are shown in the walls - door
- Show door type elements in the 3D projection. If this value is
false
, empty holes are shown in the walls - skylight
- Show skylight type elements in the 3D projection. If this value is
false
, empty holes are shown in the roofs - morph
- Show morphs in the 3D projection
- beam
- Show beam type elements in the 3D projection
- room
- Show zone type elements in the 3D projection
- trimToStoryRange
- Trims elements to the story range (see the Trim Elements to story range checkbox in the Filter and Cut Elements in 3D dialog.
- markRectFloor
- The story for the single-story marquee rectangle.
- markVertType
- Whether it is a single story or an all story marquee rectangle.
- filterMode
- The 3D filter mode. For available modes see API_3DFilterModeID enumeration. (output only)
Remarks
This structure is used to retrieve and modify the data of the 3D image item settings by the APIEnv_Get3DImageSetsID and APIEnv_Change3DImageSetsID environment functions.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Environment.h
See Also
API Types, APIEnv_Get3DImageSetsID, APIEnv_Change3DImageSetsID