API_​3DModelTypeID

Model image type in the 3D window.

    typedef enum {
        API3DModel_Block,
        API3DModel_WireFrame,
        API3DModel_Hiddenline,
        API3DModel_Shading
    } API_3DModelTypeID;

 

Members

API3DModel_Block
Block model
API3DModel_WireFrame
Wireframe model
API3DModel_Hiddenline
Hidden line model
API3DModel_Shading
Shaded model

 

Remarks

The API_3DModelTypeID type is used in the API_3DWindowInfo structure.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_Get3DWindowSetsID
APIEnv_Change3DWindowSetsID
API_3DWindowInfo
API Types