API_​3DProjectionInfo

3D projection setting parameters.

    typedef struct {
      bool        isPersp;
      char        filler_1[7];
      API_Guid    camGuid;
      API_Guid    actCamSet;
      union {
          API_PerspPars    persp;
          API_AxonoPars    axono;
      } u;
    } API_3DProjectionInfo;

 

Members

isPersp
Perspective or parallel projection settings
camGuid API version 18
Guid of the camera; if specified from a floorplan camera element
actCamSet API version 18
Guid of the camera set; if specified from a floorplan camera element
persp
Perspective settings
axono
Parallel projection settings

 

Remarks

This structure corresponds to the “3D Projection Settings…” dialog of Archicad.

The isPersp field determines whether perspective or a parallel view is set. Refer to the API_PerspPars or API_AxonoPars structures to get the right projection parameters, respectively.

Refer to the APIEnv_Get3DProjectionSetsID and APIEnv_Change3DProjectionSetsID functions to get the current settings.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_Get3DProjectionSetsID, APIEnv_Change3DProjectionSetsID, API_PerspPars, API_AxonoPars, API Types