API_​3DSightID

This is the enumeration of the applicable types of 3D sights.

    typedef enum {
        APISight_3DModel,
        APISight_Floorplan
    } API_3DSightID;

 

Remarks

These sight types are used with the APIDb_Switch3DSightID function; they represent the different 3D databases. Currently you can switch between the database behind the 3D window and the database coming from the floor plan representation of an element (this was the default in the versions prior to 3.1 of the API).

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Database.h

 

See Also

APIDb_Switch3DSightID, API Types