API_​3DStyle

3D Style parameters.

    typedef struct {
        GS::uchar_t               name[API_UniLongNameLen];
        Int32                     engineId;
        API_3DModelTypeID         model3D;
        Int32                     filler_1[2];
        bool                      transparency;
        bool                      monochromeEnabled;
        API_RGBColor              monochromeSurfaceRGB;
        API_RGBColor              monochromeContourRGB;
        bool                      bkgAsInRendering;
        bool                      chainBkgColors;
        API_RGBColor              bkgSkyColor;
        API_RGBColor              backGroundRGB;
        API_ShadingContoursID     shadCont;
        Int32                     filler_2[4];
        API_VectorShadowID        vectSunShadow;
        bool                      vectHatchOn;
        bool                      filler_3;
        short                     contourThickness;
        short                     silhouetteThickness;
        short                     vectorialHatchingThickness;
        short                     shadowContourThickness;
        short                     castShadowPercent;
        short                     shadingPercent;
        double                    shadowElevation;
        bool                      show3DHotSpotsOnly;
    } API_3DStyle;

 

Members

name[API_UniLongNameLen]
The name of the style, must be unique within a project
engineId
ID of 3D Rendering Engine
model3D
Image type of the 3D model (Block, Wireframe, Hidden Line, Shading)
transparency
Transparency in shading is in effect or not
monochromeEnabled
Monochrome rendering mode, using one uniform color for all surfaces and another one for all contours.
monochromeSurfaceRGB
Color of all surfaces (ignored if monochromeEnabled is false)
monochromeContourRGB
Color of all contours (ignored if monochromeEnabled is false)
bkgAsInRendering
Use the background specified previously in Photorendering Settings
chainBkgColors
Link sky and ground colors
bkgSkyColor
Background sky color (ignored if bkgAsInRendering is true)
backGroundRGB
Background ground color (ignored if bkgAsInRendering is true)
shadCont
Contour visibility options for shaded image mode
vectSunShadow
Vectorial sun shadow generation options
vectHatchOn
Vectorial hatch patterns are used in analytic shaded mode
contourThickness
Thickness of contour lines in pixels
silhouetteThickness
Thickness of silhouette lines in pixels
vectorialHatchingThickness
Thickness of vectorial hatching lines in pixels
shadowContourThickness
Thickness of shadow contour lines in pixels
castShadowPercent
Intensity of cast shadows
shadingPercent
Intensity of shades
shadowElevation
The absolute elevation of the horizontal plane on which the vectorial shadows will be generated. Valid only if vectSunShadow is either APIVectShad_ContOff_OneLevel or APIVectShad_ContOn_OneLevel
show3DHotSpotsOnly
Display also 2D hotspots in the 3D window

 

Remarks

The API_3DStyle structure is used by the APIEnv_Get3DStyleListID, the APIEnv_Get3DStyleID and the APIEnv_Change3DStyleID environment functions.
Changing active style can be done using the APIEnv_SetCurrent3DStyleID function.


The range of values for all kinds of line thicknesses is [1, 10].

The following settings are ignored using the OpenGL engine: vectHatchOn, silhouetteThickness, vectorialHatchingThickness, shadowContourThickness, castShadowPercent, shadingPercent.

 

Requirements

Version: API 21 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_Get3DStyleListID,
APIEnv_Get3DStyleID,
APIEnv_Change3DStyleID,
APIEnv_SetCurrent3DStyleID,
APIEnv_Create3DStyleID,
API_3DModelTypeID,
API_ShadingContoursID,
API_VectorShadowID,
API_RGBColor,
API Types