API_​3DUncutSurfaceFillType

How to display the uncut surfaces.

    typedef enum {
        API_3DDocumentPenColor,
        API_3DDocumentMaterialColorShaded,
        API_3DDocumentMaterialColorNonShaded
    } API_3DUncutSurfaceFillType;

 

Members

API_3DDocumentPenColor
Fill the uncut surfaces with a custom color.
API_3DDocumentMaterialColorShaded
Display the uncut surfaces based on the element’s surface settings.
API_3DDocumentMaterialColorNonShaded
Display the uncut surfaces based on the element’s surface settings, and shade.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

API_UniformAttributeOptions, API Types