API_​3DWindowInfo

3D Window setting parameters.

    typedef struct {
        bool       setWindowSize;
        short      hSize;
        short      vSize;
        bool       setZoom;
        double     zoomScaleX;
        double     zoomScaleY;
        double     zoomDispX;
        double     zoomDispY;
    } API_3DWindowInfo;

 

Members

setWindowSize
Resize the 3D window according to the hSize and vSize fields
hSize
Horizontal size of the 3D window in pixels
vSize
Vertical size of the 3D window in pixels
setZoom
Modify the projection zoom data according to the zoomScaleX, zoomScaleY, zoomDispX and zoomDispY fields
zoomScaleX
Horizontal scale factor of the projection (ignored if setZoom is false)
zoomScaleY
Vertical scale factor of the projection (ignored if setZoom is false)
zoomDispX
Horizontal offset of the projection (ignored if setZoom is false)
zoomDispY
Vertical offset of the projection (ignored if setZoom is false)

 

Remarks

The API_3DWindowInfo structure is used by the APIEnv_Get3DWindowSetsID and the APIEnv_Change3DWindowSetsID environment functions.
API 21 feature With API ver. 21, the parameters and functionality regarding 3D drawing options and colors was moved to the API_3DStyle structure and related functions.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_Get3DWindowSetsID
APIEnv_Change3DWindowSetsID
API Types