Structure for retrieving the transformation data of the actual editing operation.
typedef struct { API_EditCmdID typeID; bool topNodeStretched; bool filler_1[3]; API_Vector theDisp; API_Vector theAxeVect; API_Coord theOrigo; double theCosA; double theSinA; double theDispZ; double theRatio; API_Vector sectionLineDir; double filler_2[6]; } API_ActTranPars;
Members
- typeID
- Type of the editing operation
- topNodeStretched
- For vertical stretch editing, identifies the base the vertical displacement to be added to
- theDisp
- Displacement vector on the x-y plane
- theAxeVect
- Unit vector for mirroring (the base point of the mirror axis is stored in
theOrigo
) - theOrigo
- Base coordinate for Rotate, Mirror, Stretch and Resize operations
- theCosA
- Cosine of the rotation angle
- theSinA
- Sine of the rotation angle
- theDispZ
- Vertical displacement for Elevate and VertStretch operations
- theRatio
- Ratio for the Resize operation
- sectionLineDir
- Cutplane line direction unit vector
Remarks
For the utilization of this structure see the ACAPI_Notify_GetTranParams function.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Notify_GetTranParams, API_EditCmdID, API_Vector, API_Coord, API Types