API_​AddOnCommandExecutionPolicy

Execution policy of the Add-On commands.

    enum class API_AddOnCommandExecutionPolicy {
        InstantExecutionOnParallelThread,
        ScheduleForExecutionOnMainThread
    };

 

Members

InstantExecutionOnParallelThread
Immediately executes the Add-On command on a paralell thread.
ScheduleForExecutionOnMainThread
Schedules the Add-On command to execute it on the main thread.

 

Remarks

The InstantExecutionOnParallelThread is faster then the ScheduleForExecutionOnMainThread mode, but can not modify the Archicad database. Usefull for querying data.

The ScheduleForExecutionOnMainThread has full access to the Archicad database via the ACAPI functions.

 

Requirements

Version: API 25 or later
Header: APIdefs_Registration.h

 

See Also

API_AddOnCommand, API Types