API_​AddOnInfo

Textual description of the add-on.

    typedef struct {
        GS::UniString     name;
        GS::UniString     description;
        API_SSALevel      requiredSSALevel;
    } API_AddOnInfo;

 

Members

name Changed in 21
The name of the add-on, in Unicode.
description Changed in 21
The description of the functionality of the add-on, in Unicode.
requiredSSALevel Changed in 26
If the add-on requires an SSA subscription in order to function, set this member to the required minimum subscription level (see API_SSALevel).

 

Remarks

This is a member of the API_EnvirParams structure, used in the CheckEnvironment function. The description appears in the Add-On Manager dialog of Archicad. Both strings should come from a localizable resource.

When set, the requiredSSALevel field instructs Archicad to handle this add-on as dependent on Software Service Agreements. Note however, that any restrictions in functionality (e.g. disabling commands) should be implemented separately in the add-on.

From API 21 the name and description fields are in Unicode; you shouldn’t call BNZeroMemory or memset on it.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Registration.h

 

See Also

API_EnvirParams, API Types, ACAPI_Protection_IsSSALevelAtLeast