Control information of a custom data stored into the project database.
typedef struct { API_Guid id; GS::UniString *name; GSHandle data; API_AddonObjectType type; } API_AddonObject;
Members
- id
- The GUID of the AddOnObject
- name
- The name of the AddOnObject
- data
- User specified data (cannot be
nullptr
). - type
- Whether the AddOnObject is general (non-unique) or unique.
Remarks
This structure is used by the AddOnObject Manager functions, for further details refer to these sections.
Requirements
- Version: API 19 or later
- Header: APIdefs_Callback.h