Represents the two types of an AddOnObject: general (non-unique) and unique.
typedef enum { GeneralAddOnObject, UniqueAddOnObject ClientOnlyAddOnObject} API_AddonObjectType;
Members
- GeneralAddOnObject
- There can be more general (non-unique) AddOnObjects with the same name, so their name cannot be used for AddOnObject identification.
- UniqueAddOnObject
- The name of a Unique AddOnObject is unique, so their name can be used for AddOnObject identification.
- ClientOnlyAddOnObject
- There can be client only AddOnObjects, similarly to
GeneralAddOnObject
, with the difference that these objects won’t be transferred to BimCloud.
Requirements
- Version: API 21 or later
- Header: APIdefs_Callback.h