API_​AddonType

Describes the different type of add-ons.

    typedef enum {
        APIAddon_DontRegister,
        APIAddon_Normal,
        APIAddon_Preload,
        APIAddon_Unknown
    } API_AddonType;

 

Members

APIAddon_DontRegister
Some parameters (like the release version of the server application) was not correct; the add-on won’t be loaded.
APIAddon_Normal
The add-on can work in the running environment; this is the return value for most add-ons.
APIAddon_Preload
The add-on would like to get loaded when the server application starts up; e.g. because it wants to do some longer initialization.
APIAddon_Unknown

 

Remarks

This is the return value of the CheckEnvironment function, and specifies the behavior of the current add-on in the running environment.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Registration.h

 

See Also

CheckEnvironment
API Types