API_​AddParID

Possible types of a Library Part additive parameter.

    typedef enum {
        API_ZombieParT,
        APIParT_Integer,
        APIParT_Length,
        APIParT_Angle,
        APIParT_RealNum,
        APIParT_LightSw,
        APIParT_ColRGB,
        APIParT_Intens,
        APIParT_LineTyp,
        APIParT_Mater,
        APIParT_FillPat,
        APIParT_PenCol,
        APIParT_CString,
        APIParT_Boolean,
        APIParT_Separator,
        APIParT_Title,
        APIParT_BuildingMaterial,
        APIParT_Profile,
        APIParT_Dictionary
    } API_AddParID;

 

Members

API_ZombieParT
Dummy parameter type.
APIParT_Integer
Integer additional parameter type.
APIParT_Length
Length additional parameter type.
APIParT_Angle
Angle additional parameter type.
APIParT_RealNum
Real number additional parameter type.
APIParT_LightSw
Light on/off additional parameter type.
APIParT_ColRGB
RGB color additional parameter type.
APIParT_Intens
Intensity additional parameter type.
APIParT_LineTyp
Line type additional parameter type.
APIParT_Mater
Material additional parameter type.
APIParT_FillPat
Fill pattern additional parameter type.
APIParT_PenCol
Pen color additional parameter type.
APIParT_CString
C string additional parameter type.
APIParT_Boolean
Boolean additional parameter type.
APIParT_Separator
Separator line, no value.
APIParT_Title
Title text, no value.
APIParT_BuildingMaterialNew in API 21
Building material additional parameter type.
APIParT_ProfileNew in API 21
Profile additional parameter type.
APIParT_DictionaryNew in API 23
Dictionary additional parameter type. The use of this parameter type is currently limited.

 

Remarks

This identifier is mainly referenced from the API_AddParType structure.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_LibraryParts.h

 

See Also

API_AddParType,
API Types