API_​AnalyticalCrossSection

Describes or references an Structural Analytical Model Cross Section for Curve Members.

    typedef struct {
        API_CrossSectionType               crossSectionType;
        double                             width;
        double                             height;
        double                             veneerThickness;
        API_AttributeIndex                 profileAttrIndex;
        GS::Array<API_AttributeIndex>      materialAttrIndices;
        GS::HashTable<API_Guid, double>    profileParameters;
        GS::Optional<ProfileVectorImage>   profileImage;
        API_AnalyticalAlignmentType        alignment;
    } API_AnalyticalCrossSection;

 

Members

crossSectionType 24
The type of the Structural Analytical Model Cross Section (simple, custom, or predefined).
width 24
The width of the profile.
height 24
The height of the profile.
veneerThickness 24
The thickness of core-type veneer in case of simple type.
profileAttrIndex 24
The attribute index in case of predefined type.
materialAttrIndices 24
The attribute indices of the profile (see the Remarks below).
profileParameters 24
Contains the GUID of the profile modifiers and the parameter values.
profileImage 26
Contains the ProfileVectorImage of the profile if it is an Attribute Profile, or Custom Profile.
alignment 26
The alignment can be used for e.g. the Varying Segment List of a Curve Member.

 

Remarks

In case of Circle profiles, the width and height represents the circle diameter.

In case of simple type profiles with no/finish/other veneer, it contains the attribute index of the core material.

In case of simple type profiles with core veneer, it contains the attribute index of the veneer’s material on the first position and the core’s on the second.

In case of predefined type profiles, it contains as many attribute indices as many materials the profile has.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types
API_AttributeIndex