API_​AnalyticalCurve

Describes an Structural Analytical Model Curve that is either a line segment between two Structural Analytical Model Nodes, or an arc segment with a specified intermediate point.

    typedef struct {
        API_AnalyticalCurveType     type;
        API_AnalyticalNode          begNode;
        API_AnalyticalNode          endNode;
        GS::Array<API_Coord3D>      midCoords;
    } API_AnalyticalCurve;

 

Members

type 24
The type of the Structural Analytical Model Curve.
begNode 24
The beginning Node of the Structural Analytical Model Curve.
endNode 24
The ending Node of the Structural Analytical Model Curve.
midCoords 24
The intermediate point coordinates in case of arc or multi point segments.

 

Remarks

The midCoords member holds valid data only in case of arc or multi point segments. It’s content is undefined for line segments.

 

Requirements

Version: API 24 or later
Header: APIdefs_AnalyticalElements.h

 

See Also

API Types