API_​AnalyticalCurveMember

Describes an Structural Analytical Model Curve Member.

    typedef struct {
        API_AnalyticalMemberType                 analyticalMemberType;
        API_Guid                                 elemGuid;
        API_AnalyticalCrossSection               crossSection;
        API_AnalyticalCurve                      curve;
        GS::Array<API_AnalyticalNode>            internalNodes;
        double                                   ey;
        API_Vector3D                             eyVector;
        double                                   ez;
        API_Vector3D                             ezVector;
        API_AttributeIndex                       layerAttrIndex;
        API_Analytical1DFEMType                  FEMType;
        GS::Array<API_AnalyticalVaryingSegment>  varyingSegmentList;
    } API_AnalyticalCurveMember;

 

Members

analyticalMemberType 24
The type of the represented element.
elemGuid 24
The unique identifier of the represented element.
crossSection 24
The Structural Analytical Model Cross Section type.
curve 24
The curve definition.
internalNodes 24
List of eventual Internal Nodes set on this Structural Analytical Model Curve Member.
ey 24
The structure eccentricity on the Y axis.
eyVector 24
The Y axis of its local coordinate system.
ez 24
The structure eccentricity on the Z axis.
ezVector 24
The Z axis of its local coordinate system.
layerAttrIndex 24
The containing layer’s attribute index.
FEMType 24
The FEM type of the curve member.
varyingSegmentList 24
Describes the profiles of the segments, if the Member represents a multisegmented Beam/Column. The sum of the span values of the segments should be equal to 1.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types