API_​AnalyticalEdgeLoad_​Settings

Describes the Structural Analytical Model Analytical Edge Load settings.

    typedef enum {
        API_Force,
        API_Moment
    } API_AnalyticalLoad_LoadForceType;
    
    typedef struct {
        API_Guid    loadCaseId;
        API_AnalyticalLoad_LoadForceType        loadForceType;
        API_AnalyticalLoad_LoadDistributionType loadDistributionType;
        API_AnalyticalCoordSysDirection         coordinateSystemType;
        API_Vector3D                            startValue;
        API_Vector3D                            endValue;
    } API_AnalyticalEdgeLoad_Settings;
    

 

Members

loadCaseId 25
The guid of the connected Load Case.
loadForceType 25
The force type of the Analytical Edge Load. The edge force can be defined in three main directions (global or local coordinate system). An edge of the structure may be subject to a moment load. The load is defined by the direction and size of the moment.
loadDistributionType 25
The load may be either constant along the 1D member or linearly variable (trapezoidal).
coordinateSystemType 25
Defines the co-ordinate system of the member in which the load is applied. For ” Local”, coordinate system is defined by the member where is load applied
startValue 25
The start force/moment value of the Analytical Edge Load in the X, Y and Z directions.
endValue 25
The end force/moment value of the Analytical Edge Load in the X, Y and Z directions.

 

Requirements

Version: API 25 or later
Header: APIdefs_AnalyticalElements.h

 

See Also

API Types

API AnalyticalEdgeLoadType