API_​AnalyticalElemPartId

Describes the guid, contour and edge/vertex id triplet that is used for creating the API_ExportIdMappingType.

    class API_AnalyticalElemPartId{
    public:
        API_Guid           memberGuid;
        UInt32             contourIndex;
        UInt32             edgeOrVertexIndex;
    };

 

Members

memberGuid 24
The unique identifier of the member.
contourIndex 24
The contour index that identifies the member’s contour.(0 for main contour, 1,2.. for the holes)
edgeOrVertexIndex 24
The edge/vertex index that identifies the member’s edge/vertex.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types