API_​AnalyticalLink_​RigidLinkConnectionType

Describes the type of the Structural Analytical Model Analytical Rigid Link connection.

    typedef enum {
        API_RigidConnection,
        API_HingeConnection,
    } API_AnalyticalLink_RigidLinkConnectionType;

 

Members

API_RigidConnection 24
Connection is of rigid type.
API_HingeConnection 24
Connection is of hinge type.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types