Describes the Structural Analytical Model Analytical Link settings.
typedef struct { API_AnalyticalLink_LinkGeometry geometry; API_AnalyticalLink_LinkType type; API_AnalyticalLink_RigidSettings rigidSettings; API_AnalyticalLink_SpringSettings springSettings; } API_AnalyticalLink_Settings;
Members
- geometry
- The category of the link’s geometry.
- type
- The type of the Analytical Link.
- rigidSettings
- The rigidity settings if the Analytical Link is of rigid type.
- springSettings
- The spring settings if the Analytical Link is of spring type.
Requirements
- Version: API 24 or later
- Header: .\APIdefs_AnalyticalElements.h