API_​AnalyticalLinkGeometry

Describes a Structural Analytical Model Analytical Link Geometry.

    typedef struct {
        GS::Array<API_Coord3D>      	coordinates;
        GS::Array<API_AnalyticalCurve>  curves;
        API_Vector3D       	    	translationStiffnessVector;
        API_Vector3D       	    	rotationStiffnessVector;
    } API_AnalyticalLinkGeometry;

 

Members

coordinates 24
Positions of the analytical link
curves 25
Describes the joining ends of a 2D link (if they are not connected to a vertex)
translationStiffnessVector 24
Link’s translation stiffness vector in the start member’s coordinate system
rotationStiffnessVector 24
Link’s rotation stiffness vector in the start member’s coordinate system

 

Requirements

Version: API 24 or later
Header: APIdefs_AnalyticalElements.h

 

See Also

API Types