API_​AnalyticalLoad_​LoadDistributionType

Describes the distribution type of the Structural Analytical Edge Load. The load may be either constant along the 1D member or linearly variable (trapezoidal).

    typedef enum {
        API_Uniform,
        API_Trapezoid,
    } API_AnalyticalLoad_LoadDistributionType;

 

Members

API_Uniform 25
The load is constant along the 1D member.
API_Trapezoid 25
The load is linearly variable.

 

Requirements

Version: API 25 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types