API_​AnalyticalLoadCase

Describes a Structural Analytical Load Case.

Individual loads are not defined “freely”. They must be included in load cases. A load case is a group, commonly used to group loads from the same action source. The load cases correspond with the professional terminology specified in national technical standards dealing with loads of civil engineering structures.

    typedef struct {
        GS::UniString 			 		name;
        GS::UniString 			 		description;
        API_AnalyticalLoadCaseActionType 		actionType;
        API_Guid 			 		loadGroupGuid;
        API_AnalyticalLoadCaseLoadType 	 		loadType;
        GS::Optional<API_AnalyticalLoadCaseDuration> 	duration;
        API_Guid 			 		loadCaseGuid;
    } API_AnalyticalLoadCase;

 

Members

name 
Name of the load case.
description 
Description of the load case.
actionType 
Action type of the load case.
loadGroupGuid 
A unique identifier of the load group which contains the represented load case.
loadType 
Load type of the load case.
duration 
Duration of the load case.
loadCaseGuid 
A unique identifier of the represented load case.

 

Requirements

Version: API 25 or later
Header: APIdefs_AnalyticalModel.h

 

See Also

API Types

ACAPI_AnalyticalModel_GetAllAnalyticalLoadCases

ACAPI_AnalyticalModel_GetAnalyticalLoadCases

ACAPI_AnalyticalModel_GetAnalyticalLoadCase

ACAPI_AnalyticalModel_CreateAnalyticalLoadCase

ACAPI_AnalyticalModel_DeleteAnalyticalLoadCase