Describes the Structural Analytical Load Case Action type.
typedef enum { API_AnalyticalLoadCase_PermanentAction, API_AnalyticalLoadCase_VariableAction, API_AnalyticalLoadCase_AccidentalAction } API_AnalyticalLoadCaseActionType;
Members
- API_AnalyticalLoadCase_PermanentAction
- Action that is likely to act throughout a given reference period.
- API_AnalyticalLoadCase_VariableAction
- Action for which the variation in magnitude with time is neither negligible nor monotonic.
- API_AnalyticalLoadCase_AccidentalAction
- Action, usually of short duration but of significant magnitude, that is unlikely to occur on a given structure during the design working life.
Requirements
- Version: API 25 or later
- Header: APIdefs_AnalyticalModel.h