Describes a Structural Analytical Load Combination.
The combination is created from the existing load cases in the model.
typedef struct { GS::UniString name; GS::UniString description; API_AnalyticalLoadCombinationCategory category; GS::OptionalAPI_AnalyticalLoadCombinationNationalStandard> nationalStandard; GS::ArrayAPI_AnalyticalLoadFactor> loadFactors; API_Guid guid; } API_AnalyticalLoadCombination;
Members
- name
- Name of the load combination.
- description
- Description of the load combination.
- category
- The category of the load combination.
- nationalStandard
- The National code application of the load combination.
- loadFactors
- An array which contains the load cases (and the adherent coeffients) of the load combinations.
- guid
- A unique identifier of the represented load combination.
Requirements
- Version: API 25 or later
- Header: APIdefs_AnalyticalModel.h
See Also
ACAPI_AnalyticalModel_GetAnalyticalLoadCombinations
ACAPI_AnalyticalModel_GetAnalyticalLoadCombination
ACAPI_AnalyticalModel_CreateAnalyticalLoadCombination