Describes a Structural Analytical Load Group.
Load groups define “how the individual load cases may be combined together” if inserted into a load case combination.
typedef struct { GS::UniString name; API_AnalyticalLoadGroupType groupType; API_AnalyticalLoadGroupRelation relation; GS::UniString loadType; API_Guid guid; } API_AnalyticalLoadGroup;
Members
- name
- Name of the load group.
- groupType
- Group type of the load group.
- relation
- Relation of the load cases in the load group.
- loadType
- Load type of the load group.
- guid
- A unique identifier of the represented load group.
Requirements
- Version: API 25 or later
- Header: APIdefs_AnalyticalModel.h
See Also
ACAPI_AnalyticalModel_GetAnalyticalLoadGroups
ACAPI_AnalyticalModel_GetAnalyticalLoadGroup