Describes the relation of load cases in the particular load group.
The relation tells what the relation of load cases in the particular load group is.
typedef enum { API_AnalyticalLoadGroup_ExclusiveRelation, API_AnalyticalLoadGroup_StandardRelation, API_AnalyticalLoadGroup_TogetherRelation } API_AnalyticalLoadGroupRelation;
Members
- API_AnalyticalLoadGroup_ExclusiveRelation
- Two load cases from the same load group of this type will never appear in the same combination.
- API_AnalyticalLoadGroup_StandardRelation
- It allows the user to sort load cases but it does not affect the process of generation of load case combinations.
- API_AnalyticalLoadGroup_TogetherRelation
- All load cases in the same load group of this type are always inserted into every new load case combination.
Requirements
- Version: API 25 or later
- Header: APIdefs_AnalyticalModel.h