API_​AnalyticalLoadGroupType

Describes the Structural Analytical Load Group type.

This parameters tell whether the load group is used for permanent or variable loads.

    typedef enum {
        API_AnalyticalLoadGroup_PermanentLoad,
        API_AnalyticalLoadGroup_VariableLoad,
        API_AnalyticalLoadGroup_AccidentalLoad,
        API_AnalyticalLoadGroup_SeismicLoad,
        API_AnalyticalLoadGroup_MovingLoad,
        API_AnalyticalLoadGroup_TensioningLoad,
        API_AnalyticalLoadGroup_FireLoad
    } API_AnalyticalLoadGroupType;

 

Members

API_AnalyticalLoadGroup_PermanentLoad 
The type of the load group is permanent.
API_AnalyticalLoadGroup_VariableLoad 
The type of the load group is variable.
API_AnalyticalLoadGroup_AccidentalLoad 
The type of the load group is accidental.
API_AnalyticalLoadGroup_SeismicLoad 
The type of the load group is seismic.
API_AnalyticalLoadGroup_MovingLoad 
The type of the load group is moving.
API_AnalyticalLoadGroup_TensioningLoad 
The type of the load group is tensioning.
API_AnalyticalLoadGroup_FireLoad 
The type of the load group is fire.

 

Requirements

Version: API 25 or later
Header: APIdefs_AnalyticalModel.h

 

See Also

API Types

API Analytical Load Group