API_​AnalyticalMemberPartRef

Describes a Structural Analytical Model Analytical Member part.

    typedef struct {
        API_Guid                            elemGuid;
        API_AnalyticalMemberPartRefType     partRefType;
        API_InternalAnalyticalMemberPartId  partId;
        API_AMPartRefCustomVertexData	    customVertexData;
        API_AMPartRefRatioEdgeData	    ratioEdgeData;
    } API_AnalyticalMemberPartRef;

 

Members

elemGuid 24
The references Structural Analytical Model Member.
partRefType 24
The type of the reference.
partId 24
Identifies the edge or the vertex.
customVertexData 25
Contains the vertex coordinate when partRefType is API_AMPartRef_CustomVertex.
ratioEdgeData 25
Contains the ratios when partRefType is API_AMPartRef_RatioEdge.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types