API_​AnalyticalMemberPartRefType

Describes the type of the Structural Analytical Model Member Part Ref.

    typedef enum {
        API_AMPartRef_BegVertex,
        API_AMPartRef_EndVertex,
        API_AMPartRef_CustomVertex,
        API_AMPartRef_Edge,
        API_AMPartRef_RatioEdge,
        API_AMPartRef_Surface,
        API_AMPartRef_CustomSurface
        API_AMPartRef_CustomEdge
    } API_AnalyticalMemberPartRefType;

 

Members

API_AMPartRef_BegVertex 24
References a beginning node of a curve or an arbitrary node of a surface.
API_AMPartRef_EndVertex 24
References an ending node.
API_AMPartRef_CustomVertex 24
References an internal node.
API_AMPartRef_Edge 24
References an edge.
API_AMPartRef_RatioEdge 25
References a part of an edge.
API_AMPartRef_Surface 24
References a surface.
API_AMPartRef_CustomSurface 25
References a subregion of a surface.
API_AMPartRef_CustomEdge 25
References a custom edge of a surface.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types