API_​AnalyticalModelVariation

Describes the Model Variation that is used for creating the Structural Analytical Model.

    typedef struct {
        API_Guid                                   renovationFilterGuid;
        GS::HashTable<API_AttributeIndex, Int32>   layerConnectionClassIds;
    } API_AnalyticalModelVariation;

 

Members

renovationFilterGuid 24
The unique identifier of the renovation state.
layerConnectionClassIds 24
The list of Connection Classes that connect the objects represented in the Structural Analytical Model.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types