API_​AnalyticalPointLoad_​Settings

Describes the Structural Analytical Model Analytical Point Load settings.

    typedef enum {
        API_Force,
        API_Moment
    } API_AnalyticalLoad_LoadForceType;
    
    typedef struct {
        API_Guid   loadCaseId;
        API_AnalyticalLoad_LoadForceType       loadForceType;
        API_AnalyticalCoordSysDirection        coordinateSystemType;
        double                                 xValue;
        double                                 yValue;
        double                                 zValue;
        } API_AnalyticalPointLoad_Settings;
    

 

Members

loadCaseId 25
The guid of the connected Load Case.
loadForceType 25
The force type of the Analytical Point Load. The point force can be defined in three main directions (global or local coordinate system). A node of the structure may be subject to a moment load. The load is defined by the direction and size of the moment.
coordinateSystemType 25
The coordinate system type of the Analytical Point Load.
xValue 25
The force/moment value in X direction of the Analytical Point Load
yValue 25
The force/moment value in Y direction of the Analytical Point Load
zValue 25
The force/moment value in Z direction of the Analytical Point Load

 

Requirements

Version: API 25 or later
Header: APIdefs_AnalyticalElements.h

 

See Also

API Types

API AnalyticalPointLoadType