Contains the Structural Analytical Model Analytical Member Release values.
typedef struct { API_AnalyticalRigidityType ux; double stiffnessX; API_AnalyticalRigidityType uy; double stiffnessY; API_AnalyticalRigidityType uz; double stiffnessZ; API_AnalyticalRigidityType fix; double stiffnessFix; API_AnalyticalRigidityType fiy; double stiffnessFiy; API_AnalyticalRigidityType fiz; double stiffnessFiz; API_AnalyticalMemberPartRef amPartRef; } API_AnalyticalReleaseDescription;
Members
- ux
- Translation type in X direction.
- stiffnessX
- Translation value in X direction in case of Custom type.
- uy
- Translation type in Y direction.
- stiffnessY
- Translation value in Y direction in case of Custom type.
- uz
- Translation type in Z direction.
- stiffnessZ
- Translation value in Z direction in case of Custom type.
- fix
- Rotation type in X direction.
- stiffnessFix
- Rotation value in X direction in case of Custom type.
- fiy
- Rotation type in Y direction.
- stiffnessFiy
- Rotation value in Y direction in case of Custom type.
- fiz
- Rotation type in Z direction.
- stiffnessFiz
- Rotation value in Z direction in case of Custom type.
- amPartRef
- The Structural Analytical Member part referenced.
Requirements
- Version: API 24 or later
- Header: .\APIdefs_AnalyticalModel.h