API_​AnalyticalRigidityType

Describes the type of the Structural Analytical Model rigidity class type.

    typedef enum {
        API_FreeType,
        API_RigidType,
        API_CustomType,
        API_RigidCompressionOnlyType,
        API_RigidTensionOnlyType,
        API_CustomCompressionOnlyType,
        API_CustomTensionOnlyType,
    } API_AnalyticalRigidityType;

 

Members

API_FreeType 24
The element is free for translation or rotation.
API_RigidType 24
The element is rigid against translation or rotation.
API_CustomType 24
The element allows translation or rotation with a specific value.
API_RigidCompressionOnlyType 24
The element is rigid against compression.
API_RigidTensionOnlyType 24
The element is rigid against tension.
API_CustomCompressionOnlyType 24
The element allows compression until a certain amount of force is applied.
API_CustomTensionOnlyType 24
The element allows tension until a certain amount of force is applied.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types