API_​AnalyticalSupport_​SupportValues

Contains the Structural Analytical Model Analytical Support values.

    typedef struct {
        API_AnalyticalRigidityType     xType;
        double                         xValue;
        API_AnalyticalRigidityType     yType;
        double                         yValue;
        API_AnalyticalRigidityType     zType;
        double                         zValue;
        API_AnalyticalRigidityType     rxType;
        double                         rxValue;
        API_AnalyticalRigidityType     ryType;
        double                         ryValue;
        API_AnalyticalRigidityType     rzType;
        double                         rzValue;
    } API_AnalyticalSupport_SupportValues;

 

Members

xType 24
Translation type in X direction.
xValue 24
Translation value in X direction in case of Custom type.
yType 24
Translation type in Y direction.
yValue 24
Translation value in Y direction in case of Custom type.
zType 24
Translation type in Z direction.
zValue 24
Translation value in Z direction in case of Custom type.
rxType 24
Rotation type in X direction.
rxValue 24
Rotation value in X direction in case of Custom type.
ryType 24
Rotation type in Y direction.
ryValue 24
Rotation value in Y direction in case of Custom type.
rzType 24
Rotation type in Z direction.
rzValue 24
Rotation value in Z direction in case of Custom type.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalElements.h

 

See Also

API Types