API_​AnalyticalSurface

Describes the Structural Analytical Model Surface of a Structural Analytical Model Surface Member.

    typedef struct {
        API_AnalyticalSurfaceType         surfaceType;
        API_AnalyticalPlaneSurface        planeSurface;
        API_AnalyticalCylinderSurface     cylinderSurface;
    } API_AnalyticalSurface;

 

Members

surfaceType 24
Type of the surface’s geometry.
planeSurface 24
Describes the geometry of the surface by a plane. Only used when the surfaceType is API_AnalyticalSurface_PlaneType.
cylinderSurface 24
Describes the geometry of the surface by a cylinder. Only used when the surfaceType is API_AnalyticalSurface_CylinderType.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types