Describes the Structural Analytical Model Analytical Surface Load settings.
typedef struct { API_Guid loadCaseId; API_AnalyticalCoordSysDirection coordinateSystemType; double xValue; double yValue; double zValue; } API_AnalyticalSurfaceLoad_Settings;
Members
- loadCaseId
- The guid of the connected Load Case.
- coordinateSystemType
- Defines the co-ordinate system of the member in which the load is applied. For ” Local”, coordinate system is defined by the member where is load applied
- xValue
- The force/moment value in X direction of the Analytical Surface Load
- yValue
- The force/moment value in Y direction of the Analytical Surface Load
- zValue
- The force/moment value in Z direction of the Analytical Surface Load
Requirements
- Version: API 25 or later
- Header: APIdefs_AnalyticalElements.h