API_​AnalyticalSurfaceLoadType

Describes a Structural Analytical Model Member Surface Load.

    typedef struct {
        API_AnalyticalSurfaceLoad_Settings    surfaceLoadSettings;
        API_AnalyticalMemberPartRef        loadedMemberPartRef;
    } API_AnalyticalSurfaceLoadType;

 

Members

surfaceLoadSettings 
The Analytical Surface Load settings.
loadedMemberPartRef 
The Analytical Member part reference where the Analytical Surface Load is applied.

 

Remarks

An Surface Load element can be created with the aid of ACAPI_Element_Create and it can be removed via the ACAPI_Element_Delete function. Currently the ACAPI_Element_Change function is unavailable for Analytical Surface Loads.

Requirements

Version: API 25 or later
Header: APIdefs_AnalyticalElements.h

 

See Also

API Types

API Element

ACAPI_Element_Get

ACAPI_Element_Create

ACAPI_Element_Delete