API_​AnalyticalSurfaceMember

Describes a Structural Analytical Model Surface Member.

    typedef struct {
        API_AnalyticalMemberType                  analyticalMemberType;
        API_Guid                                  elemGuid;
        API_AnalyticalSurface                     surface;
        GS::Array<API_AnalyticalCurve>            contour;
        GS::Array<GS::Array<API_AnalyticalCurve>> holeContours;
        GS::Array<API_AnalyticalNode>             internalNodes;
        double                                    thickness;
        API_Vector3D                              lcsXVector;
        double                                    ez;
        API_Vector3D                              ezVector;
        API_AttributeIndex                        materialAttrIndex;
        API_AttributeIndex                        layerAttrIndex;
        API_Analytical1DFEMType                   FEMType;
        API_Guid                                  groupId;
    } API_AnalyticalSurfaceMember;

 

Members

analyticalMemberType 24
The type of the represented element.
elemGuid 24
The unique identifier of the represented element.
surface 24
The type of the surface.
contour 24
The contour as a list of Structural Analytical Model Curves.
holeContours 24
The list of eventual holes as a list of hole contours.
internalNodes 24
List of eventual Internal Nodes set on this Structural Analytical Model Curve Member.
thickness 24
The structure thickness.
lcsXVector 26
The X axis of the local coordinate system.
eccentricity 24
The structure eccentricity.
materialAttrIndex 24
The material attribute index that references the material in the system.
layerAttrIndex 24
The containing layer’s attribute index.
FEMType 24
The FEM type of the surface member.
groupId 24
The unique identifier of the group containing the element.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types
API_AttributeIndex