Describes a Structural Analytical Model Varying Segment for Curve Members.
struct API_AnalyticalVaryingSegment { API_AnalyticalCrossSection begProfile; GS::Optional<API_AnalyticalCrossSection> endProfile; double span; };
Members
- begProfile
- The begin profile of the segment. If the segment is not tapered, this is also the end profile.
- endProfile
- If the segment is tapared, this describes the end profile of the segment.
- span
- Length of the segment in percentage. The full length is the length of the Curve Member.
Requirements
- Version: API 26 or later
- Header: .\APIdefs_AnalyticalModel.h