API_​ApplicationTypeID

The ID of the server application the add-on is called from.

    typedef enum {
        APIAppl_ArchiCADID
    } API_ApplicationTypeID;

 

Members

APIAppl_ArchiCADID
The server application is Archicad.

 

Remarks

Use these data if you have to depend on the server application.

Call the ACAPI_Environment function with the APIEnv_ApplicationID function code or the ACAPI_GetReleaseNumber function to get this data.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Registration.h

 

See Also

APIEnv_ApplicationID, ACAPI_GetReleaseNumber , API Types