The representation of the area dimensioning on the Preferences / Dimensioning tab page.
typedef struct { API_AreaTypeID unit; short lenDecimals; bool hide0Dec; char filler_0; } API_AreaDimFormat;
Members
- unit
- measurement unit, for the possible values see API_AreaTypeID
- lenDecimals
- number of decimals (0, 1, 2, 3, 4)
- hide0Dec
- hide zeros at the right of the decimal point
Remarks
This structure is a member of API_DimensionPrefs.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Environment.h
See Also
API_DimensionPrefs
API_LengthDimFormat
API_AngleDimFormat
APIEnv_GetPreferencesID
API Types