API_​ArrowID

Describes the different arrow types.

    typedef enum {
        APIArr_EmptyCirc,
        APIArr_CrossCircIs,
        APIArr_FullCirc,
        APIArr_SlashLine15,
        APIArr_OpenArrow15,
        APIArr_ClosArrow15,
        APIArr_FullArrow15,
        APIArr_SlashLine30,
        APIArr_OpenArrow30,
        APIArr_ClosArrow30,
        APIArr_FullArrow30,
        APIArr_SlashLine45,
        APIArr_OpenArrow45,
        APIArr_ClosArrow45,
        APIArr_FullArrow45,
        APIArr_SlashLine60,
        APIArr_OpenArrow60,
        APIArr_ClosArrow60,
        APIArr_FullArrow60,
        APIArr_SlashLine90,
        APIArr_PepitaCirc,
        APIArr_BandArrow,
        APIArr_HalfArrowCcw15,
        APIArr_HalfArrowCw15,
        APIArr_HalfArrowCcw30,
        APIArr_HalfArrowCw30,
        APIArr_HalfArrowCcw45,
        APIArr_HalfArrowCw45,
        APIArr_HalfArrowCcw60,
        APIArr_HalfArrowCw60,
        APIArr_SlashLine75
    } API_ArrowID;

 

Members

APIArr_EmptyCirc
Empty circle.
APIArr_CrossCircIs
Crossline + empty circle (inside the circle).
APIArr_FullCirc
Full circle.
APIArr_SlashLine15
15 degree slash line.
APIArr_OpenArrow15
15 degree open arrow.
APIArr_ClosArrow15
15 degree closed arrow (triangle).
APIArr_FullArrow15
15 degree full arrow.
APIArr_SlashLine30
30 degree slash line.
APIArr_OpenArrow30
30 degree open arrow.
APIArr_ClosArrow30
30 degree closed arrow (triangle).
APIArr_FullArrow30
30 degree full arrow.
APIArr_SlashLine45
45 degree slash line.
APIArr_OpenArrow45
45 degree open arrow.
APIArr_ClosArrow45
45 degree closed arrow (triangle).
APIArr_FullArrow45
45 degree full arrow.
APIArr_SlashLine60
60 degree slash line.
APIArr_OpenArrow60
60 degree open arrow.
APIArr_ClosArrow60
60 degree closed arrow (triangle).
APIArr_FullArrow60
60 degree full arrow.
APIArr_SlashLine90
90 degree slash line.
APIArr_PepitaCirc
Pepita circle.
APIArr_BandArrow
Lane arrow (double line).
APIArr_HalfArrowCcw15 API version 19
15 degree rightwards harpoon with barb upwards.
APIArr_HalfArrowCw15 API version 19
15 degree rightwards harpoon with barb downwards.
APIArr_HalfArrowCcw30 API version 19
30 degree rightwards harpoon with barb upwards.
APIArr_HalfArrowCw30 API version 19
30 degree rightwards harpoon with barb downwards.
APIArr_HalfArrowCcw45 API version 19
45 degree rightwards harpoon with barb upwards.
APIArr_HalfArrowCw45 API version 19
45 degree rightwards harpoon with barb downwards.
APIArr_HalfArrowCcw60 API version 19
60 degree rightwards harpoon with barb upwards.
APIArr_HalfArrowCw60 API version 19
60 degree rightwards harpoon with barb downwards.
APIArr_SlashLine75 API version 19
75 degree slash line.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_ArrowData, API Types