Represents an general segment.
typedef struct { API_ModelElemStructureType modelElemStructureType; API_AttributeIndex buildingMaterial; bool circleBased; API_AttributeIndex profileAttr; short profileType; API_AssemblySegmentUniformityID uniformity; double nominalWidth; double nominalHeight; bool isWidthAndHeightLinked; double endWidth; double endHeight; bool isEndWidthAndHeightLinked; double relativeHomeStoryLevel; } API_AssemblySegmentData;
Members
- modelElemStructureType
- The structure type of the column’s segment.
- buildingMaterial
- Building Material index of column’s hatch. Used only, if structure type is API_BasicStrucure.
- circleBased
- Defines whether the column is circular (true) or rectangular/profiled (false).
- profileAttr
- Attribute index of the extruded profile.
Used only, if structure type is API_ProfileStructure. - profileType
- The type of the profile:
APISect_Normal Simple cross section element
APISect_Poly Profiled cross section element
APISect_Slanted Slanted cross section element
APISect_Trapez Trapezoid cross section element. - uniformity
- Uniformity of the segment geometry.
- nominalWidth
- Nominal width of segment.
- nominalHeight
- Nominal height of segment.
- isWidthAndHeightLinked
- State of linking between width and height.
- endWidth
- Width of end in case of not homogeneous uniformity.
- endHeight
- Height of end in case of not homogeneous uniformity.
- isEndWidthAndHeightLinked
- State of linking between end width and end height in case of not homogeneous uniformity.
- relativeHomeStoryLevel
- Relative Home Story Level of the segment, should not be interpreted on default, only on instance. Output only parameter.
Requirements
- Version: API 23 or later
- Header: APIdefs_Elements.h
See Also
API_BeamType, API_ColumnType,
API_BeamSegmentType, API_ColumnSegmentType,
API_ElementMemo