API_​AssemblySegmentProfileData

Represents an segment of the beam element.

    typedef struct {
        UInt32                        segmentIndex;
        ProfileVectorImage            *customOrigProfile;
        ProfileVectorImage            *stretchedProfile;
    } API_AssemblySegmentProfileData;

 

Members

segmentIndex
Index of the segment.
customOrigProfile
Original custom profile.
stretchedProfile
Stretched profile.

 

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API_BeamType, API_ColumnType,
API_BeamSegmentType, API_ColumnSegmentType, API_ElementMemo