Represents a segment scheme.
typedef struct { API_AssemblySegmentLengthTypeID lengthType; double fixedLength; double lengthProportion; } API_AssemblySegmentSchemeData;
Members
- lengthType
- Segment length type.
- fixedLength
- Use this if
lengthType
is APIAssemblySegment_Fixed. - lengthProportion
- Use this if
lengthType
is APIAssemblySegment_Proportional.
Requirements
- Version: API 23 or later
- Header: APIdefs_Elements.h
See Also
API_BeamType, API_ColumnType,
API_BeamSegmentType, API_ColumnSegmentType, API_ElementMemo