API_​Attribute

Describes the different attributes.

    typedef union {
        API_Attr_Head                header;
        API_PenType                  pen;
        API_LayerType                layer;
        API_LinetypeType             linetype;
        API_FilltypeType             filltype;
        API_CompWallType             compWall;
        API_MaterialType             material;
        API_LayerCombType            layerComb;
        API_ZoneCatType              zoneCat;
        API_FontType                 font;
        API_ProfileAttrType          profile;
        API_PenTableType             penTable;
        API_DimensionAttrType        dimension;
        API_ModelViewOptionsType     modelViewOpt;
        API_MEPSystemType            mepSystem;
        API_OperationProfileType     operationProfile;
        API_BuildingMaterialType     buildingMaterial;
    } API_Attribute;

 

Members

header
A common header for all the attribute types. It contains information which applies to all the attribute types.
pen
A pen attribute.
layer
A layer attribute.
linetype
A line type attribute.
filltype
A fill type attribute.
compWall
A composite wall attribute.
material
A material attribute.
layerComb
A layer combination attribute.
zoneCat
A zone category attribute.
font
A font attribute.
profile 10
A custom profile attribute for walls, beams, and columns.
penTable 10
A named pen table attribute..
dimension 10
A dimension style attribute.
modelViewOpt 10
A collection of display & output options as an attribute.
mepSystem 10
A MEP System attribute.
operationProfile 15
An Energy Evaluation operation profile.
buildingMaterial 17
A building material attribute.

 

Remarks

Database items named attributes are global collections of layers, pen colors, surface materials, fill patterns, etc. that are available to all eligible tools. They are referenced by indices and changes to an attribute effects every element that uses that attribute. Attributes can be accessed and edited through the Options menu.

API functions operating on the attribute set begin with the ACAPI_Attribute_ prefix, refer to the Attribute Manager for more details.

Many attribute related functions use the API_Attribute structure on the parameter list. As a general rule, you have to fill the required fields in the union, then Archicad parses the request based on the values, and passes the return parameters in the same parameter. This is why most of the functions do not have the const directive in the prototypes.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head, API_AttributeIndex,
API_PenType, API_LayerType, API_LinetypeType, API_FilltypeType, API_CompWallType, API_MaterialType, API_LayerCombType, API_ZoneCatType, API_FontType,
API_ProfileAttrType, API_PenTableType, API_DimensionAttrType, API_ModelViewOptionsType,
API_MEPSystemType,
API_OperationProfileType,
API_BuildingMaterialType,
Attribute Manager, API Types