Describes the extended information for different attributes.
typedef struct { API_DashItems **ltype_dashItems; API_LineItems **ltype_lineItems; API_FillLine **fill_lineItems; double **fill_lineLength; API_SymbolHatchDef sfill_Items; API_CWallComponent **cwall_compItems; API_LayerStat **layer_statItems; API_AddParType **zone_addParItems; } API_AttributeDef;
Members
- ltype_dashItems
- Contains the data describing dashed lines.
- ltype_lineItems
- Contains the data describing symbol lines.
- fill_lineItems
- Contains vectorial fill details.
- fill_lineLength
- Contains the lengths of individual parts for vectorial fills. It contains the description of each fill line item in dash-gap length pairs.
- sfill_Items
- Contains symbol fill details.
- cwall_compItems
- Describes the simple fills contained in composite structures.
- layer_statItems
- Describes the visibility and openness of every layer in a layer set.
- zone_addParItems
- Contains the library part parameters of a zone category.
Remarks
This structure contains the extended information for certain attribute types.
Use the Attribute Manager functions to operate on this data.
See also the extension of this structure: API_AttributeDefExt.
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Attributes.h
See Also
API_DashItems, API_LineItems, API_FillLine, API_SymbolHatchDef, API_CWallComponent, API_LayerStat, API_AddParType
API_AttributeDefExt, Attribute Manager, API Types