Describes the extended information for different attributes.
typedef struct { API_DashItems **ltype_dashItems; API_LineItems **ltype_lineItems; API_FillLine **fill_lineItems; double **fill_lineLength; API_SymbolHatchDef sfill_Items; API_CWallComponent **cwall_compItems; API_CWallLineComponent **cwall_compLItems; API_LayerStat **layer_statItems; API_AddParType **zone_addParItems; ProfileVectorImage *profile_vectorImageItems; GS::HashTable<PVI::ProfileParameterId, GS::UniString> *profile_vectorImageParameterNames; API_PenType **penTable_Items; API_DailyProfile **op_dailyProfiles; API_DailyProfileUsage **op_dailyProfileUsages; API_HourlyProfile **op_hourlyProfiles; Int32 filler_1[14]; } API_AttributeDefExt;
Members
- ltype_dashItems
- Contains the data describing dashed lines.
- ltype_lineItems
- Contains the data describing symbol lines.
- fill_lineItems
- Contains vectorial fill details.
- fill_lineLength
- Contains the lengths of individual parts for vectorial fills. It contains the description of each fill line item in dash-gap length pairs.
- sfill_Items
- Contains symbol fill details.
- cwall_compItems
- Describes the simple fills contained in composite structures.
- cwall_compLItems
- Describes the lines separate the simple fills contained in composite structures.
- layer_statItems
- Describes the visibility and openness of every layer in a layer set.
- zone_addParItems
- Contains the library part parameters of a zone category.
- profile_vectorImageItems
- Elements of a custom profile for walls, beams, and columns. The handle contains a serialized
HGX::VectorImage
. - profile_vectorImageParameterNames
- Parameter names of the new profiles.
- penTable_Items
- Contains the 255 pens of a named pen table (
Pen records are stored from index 0 to 254).
- op_dailyProfiles
- The daily profiles for an operation profile (Energy Evaluation)
- op_dailyProfileUsages
- The daily profile usages for an operation profile (Energy Evaluation)
- op_hourlyProfiles
- The hourly profile usages for an operation profile (Energy Evaluation)
Remarks
This structure contains the extended information for certain attribute types.
Use the Attribute Manager functions to operate on this data.
Requirements
- Version: API 5.1 or later
- Header: APIdefs_Attributes.h
See Also
API_DashItems, API_LineItems, API_FillLine, API_SymbolHatchDef, API_CWallComponent, API_CWallLineComponent, API_LayerStat, API_AddParType,
API_ProfileAttrType, API_PenType, API_PenTableType,
API_DailyProfile, API_DailyProfile, API_HourlyProfile,
Attribute Manager, API Types